Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
From 02:34 UTC until 05:30 UTC and also from 06:11 until 06:23 UTC on 2025-10-20, we observed Elevated Afterpay and Clearpay errors. The issue was external to Stripe and is now resolved.
Posted Oct 20, 2025 - 07:04 UTC
Monitoring
We are seeing recovery for Afterpay and Clearpay payments. The payment method provider has let us know they have fixed the issue for most regions. We are monitoring to ensure a full return to normal service levels.
Posted Oct 20, 2025 - 05:41 UTC
Identified
We continue to see elevated errors for Afterpay and Clearpay payments. At this time, the issue appears external to Stripe. We are in communication with the payment method provider as they work on a fix.
Posted Oct 20, 2025 - 04:15 UTC
Investigating
We're investigating elevated errors for Afterpay and Clearpay payments.
Posted Oct 20, 2025 - 03:16 UTC
This incident affected: Acquirers and payment methods.