Live status
History
Service Disruption for Issuers and Acquirers in Italy
Incident Report for Stripe
Resolved
Between 10:24 UTC on November 28th and 17:10 UTC on November 29th, we saw service disruptions for Issuers and Acquirers in Italy. This issue was caused by damage to the physical infrastructure used to provide internet service to Italy. All repairs have been completed and transactions are now processing as expected. This issue is considered resolved although we will continue to monitor.
Posted Nov 29, 2024 - 20:39 UTC
Update
We are continuing to monitor and will post updates as they become available. There are no issues with Stripe systems at this time.
Posted Nov 29, 2024 - 14:30 UTC
Identified
As of 10:24 UTC on November 28th, we have seen service disruption to Issuers and Acquirers in Italy. Stripe remains operational. The issue seems to be impacting multiple banks in the region. We are continuing to monitor and will post further updates as they become available.
Posted Nov 29, 2024 - 12:57 UTC
This incident affected: Acquirers and payment methods.