Live status
History

Elevated PromptPay Errors

Incident Report for Stripe

Resolved

From 19:10 - 23:40 UTC March 22nd, we saw elevated errors on PromptPay payments as a result of an external issue. This is now resolved.
Posted Mar 23, 2025 - 00:13 UTC

Investigating

We are seeing elevated errors on PromptPay payments. No issues have been identified with Stripe systems at this time. Our engineers will continue to monitor the issue with PromptPay.
Posted Mar 22, 2025 - 22:09 UTC
This incident affected: Acquirers and payment methods.