Live status
History

Delays with GBP Debits, UK Bank Transfers and Top Ups

Incident Report for Stripe

Resolved

The issues with GBP Debits payment processing, Top Ups, and UK Bank Transfers are now resolved.
Posted Feb 04, 2025 - 13:25 UTC

Monitoring

GBP Debits payment processing, UK Bank Transfers, and Top Ups are recovering. We are working closely with our banking partner to ensure that the issue is resolved as quickly as possible. No action is required on your part.
Posted Feb 03, 2025 - 15:42 UTC

Investigating

We are experiencing delays in GBP Debits payment processing, UK Bank Transfers and Top Ups as a result of a banking partner outage. We are working closely with them to resolve the issue as quickly as possible. No action is required on your part.
Posted Jan 31, 2025 - 19:17 UTC
This incident affected: Acquirers and payment methods.