Live status
History
Global IT incident affecting inflow of emails
Incident Report for Stripe
Resolved
The global IT incident impacting email communications since July 19 has been resolved. Stripe's services remained operational throughout. All support channels, including email, are operating as normal.
Posted Jul 23, 2024 - 10:00 UTC
Monitoring
Stripe is aware of the global IT incident starting on July 19th. Our services remain available and operational. Some users report difficulty reaching our email support channel. This issue is not caused by Stripe’s systems. Our email, phone, and chat support remain accessible.
Posted Jul 19, 2024 - 11:43 UTC