Live status
History
Elevated Affirm errors
Incident Report for Stripe
Resolved
From 20:28 November 25th – 03:28 November 26th UTC, we saw elevated errors on Affirm payments. This is now resolved.
Posted Nov 26, 2024 - 04:48 UTC
Identified
As of 20:28 UTC, we're seeing elevated errors on Affirm payments. We've identified this to be caused by Affirm, and are continuing to monitor the issue.
Posted Nov 26, 2024 - 02:44 UTC
This incident affected: Acquirers and payment methods.