Live status
History

Disruption to phone and chat support channels

Incident Report for Stripe

Resolved

Between 20:16–23:04 UTC, we experienced an issue with engaging Stripe's support teams by phone or chat. During the time of this issue, no other methods to engage Stripe support were affected. This is now resolved.
Posted Apr 17, 2025 - 23:47 UTC

Investigating

Starting at 20:16 UTC, we identified an issue with engaging Stripe's support teams by phone or Chat. Other support methods are not affected. We’re continuing to investigate the issue and will post updates soon.
Posted Apr 17, 2025 - 20:53 UTC
This incident affected: Stripe core components.