Live status
History
Dashboard Reporting inaccessible for some merchants
Incident Report for Stripe
Resolved
From 18:40–20:57 UTC, Dashboard Reporting was inaccessible for some users. This is now resolved.
Posted Oct 14, 2024 - 21:06 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 14, 2024 - 21:04 UTC
Identified
We’re currently seeing an issue resulting in Dashboard Reporting being inaccessible for some users beginning at 18:40 UTC. We’ve identified the cause, and are working on a fix.
Posted Oct 14, 2024 - 20:36 UTC
This incident affected: Stripe core components.