Live status
History
Elevated Paypal errors
Incident Report for Stripe
Resolved
From 11:38 –13:00 UTC, we saw elevated errors on Paypal payments. This is now resolved.
Posted Nov 21, 2024 - 13:16 UTC
Identified
As of 11:38 UTC, we’re seeing elevated errors on Paypal payments. We’ve identified this to be caused by Paypal, and are continuing to monitor the issue.
Posted Nov 21, 2024 - 12:38 UTC
This incident affected: Acquirers and payment methods.