Live status
History
Request-a-call and chat support unavailable
Incident Report for Stripe
Resolved
From 03:30–06:21 UTC, we saw issues responding to support requests via phone call and chat. Requests to our other support channels were unaffected. This is now resolved.
Posted Sep 26, 2024 - 06:40 UTC
Investigating
We’re currently investigating issues responding to support requests via phone call and chat. Requests to our other support channels are unaffected. We’ll post an update soon.
Posted Sep 26, 2024 - 04:45 UTC
This incident affected: Stripe core components.